Amazon Prime Video Shows Availabilities Maintenance
Incident Report for fabricorigin
Resolved
This incident has been resolved.
Posted Jul 12, 2023 - 14:12 UTC
Identified
We've identified an issue with the Amazon Prime Video Shows Availabilities not updating and we are currently working on fixing the issue.
Posted Jul 10, 2023 - 20:03 UTC
This incident affected: availability sources.