Expanded Coverage for Peacock and Tubi
Incident Report for fabricorigin
Resolved
This incident has been resolved.
Posted Jun 20, 2023 - 13:47 UTC
Investigating
Fabric Origin has expanded the title coverage for streaming services Peacock and Tubi.
Posted Jun 20, 2023 - 13:46 UTC
This incident affected: Product updates, Entertainment API, media manager, and availability sources.